AI Tutor x Pixio - Polycraft is down at the moment – Incident details

Polycraft is down at the moment

Resolved
Partial outage
Started 5 months agoLasted 4 days

Affected

Pixio Web App

Partial outage from 10:42 PM to 10:28 PM, Operational from 10:28 PM to 6:52 PM, Partial outage from 6:52 PM to 10:23 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.